wfyj.net
当前位置:首页 >> linux怎么安装pip3 >>

linux怎么安装pip3

用python3 setup.py install安装。 python setup.py install使用的是2的版本,你用python3来执行就是安装的3的版本。

pip一般用于在DOS命令下安装库文件; pip的所有命令如下: 安装库文件示例:

看你用什么系统了 在windows中,把哪个版本的加在环境变量中,pip以后就装在了哪个site-package中了 linux下,就是python3.x用pip3,默认的是pip,用在python2.x中

最简单的方式是使用Python的pip包管理器,pip可以自动根据包的名称搜索并下载包,安装包时,自动先安装所依赖的包,十分简单方便。 在linux中可以使用以下代码安装pip包管理器: sudo apt-get install python-pip安装好pip包管理器后,安装包就...

用python3 setup.py install安装。 python setup.py install使用的是2的版本,你用python3来执行就是安装的3的版本。

1、如果是windows,建议在安装路径下的pip分别改成pip2和pip3进行区分 2、如果是Linux, 也是同样的办法,将pip的软链接删除,增加pip2和pip3的软件进行区分。pip会自动安装对应的包

查看了一下要求: Requirements Python 2.7 or Python 3.3+ Works on Linux, Windows, Mac OSX, BSD 所以是支持的,那就: pip3 install scrapy

一般来说,安装Python3或者2都会在环境变量里面添加响应的环境变量,而使用pip会从环境变量里面取使用的路径,比如我装的是Python3.5: 而像题主所说的,3和2都安装的,你可以去环境变量里面查看下,有四种可能性: ①只有Python3的路径,那么你...

Permission denied很明显说明问题所在,没有权限 在ubuntu上应该用sudo python setup.py install 不知道在centos上用什么,应该是su吧

CosmoKey linux下,Python 多版本共存,及Pip,Easy_install 安装扩展包 Python2与Python3共存 安装Python3后,建立ln,使用Python(Python2),Python3 来区分两个版本 使用sudo apt-get install python3-setuptools 安装Easy_install 再使用su...

网站首页 | 网站地图
All rights reserved Powered by www.wfyj.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com